Методические рекомендации к уроку составила: Дикарева А.С. Учитель информатики и ИКТ
МОУ «СОШ № 25 при МаГК» г. Магнитогорска
Цель урока: сформировать у учащихся целостного представления о логическом типе
данных языка Паскаль.
Задачи урока:
образовательные: формирование знаний и умений учащихся по теме “Логический
тип данных языка Паскаль”, операции с логическими операциями, приоритет
логических операций.
развивающие: развитие приемов умственной деятельности (обобщение, анализ,
синтез, сравнение); развитие внимания, восприятия.
воспитательные: развивать познавательный интерес к программированию,
повышать информационную культуру учащихся.
Тип урока: урок изучения нового материала.
Форма проведения: лекция, практическая работа
Оборудование: компьютер, проектор, компьютеры для учащихся.
Программное обеспечение: презентация в PowerPoint по теме урока “Логический тип
данных в языке программирования Pascal ”
Рекомендации по проведению лекции
Лучше всего, для восприятия учащимися лекционного материала, сопровождать лекцию
демонстрацией слайдов презентации. Выделить важные моменты в отдельные слайды.
Схему и листинг программы Turbo Pascal заготовить учащимся в виде раздаточного
материала – это экономит время и лучше воспринимается учащимися.
План урока
1. Организационный момент –5 минутs
2. Лекция – 10 минут
3. Практическая работа – 25 минут
4. Подведение итогов урока – 3 минуты
5. Домашнее задание – 2 минуты
Ход урока
I. Организационный момент
Учитель. Здравствуйте, ребята! Прежде чем приступить к серьезной работе, настроиться
на получение большого потока информации, я предлагаю Вам проверить домашнюю работу
с прошлого урока.
Учащиеся показывают у доски решение задач по логике, подготовленные дома.Методические рекомендации к уроку составила: Дикарева А.С. Учитель информатики и ИКТ
МОУ «СОШ № 25 при МаГК» г. Магнитогорска
Учитель. Большое спасибо. Сегодня на уроке мы должны представить целостную картину
о логическом типе данных и как его можно представить на языке программирования
Pascal. Приготовьтесь к внимательному восприятию информации. По ходу лекции будет
демонстрироваться презентация, в которой отображены важные моменты темы. Их
необходимо записать себе в тетрадь. Итак, тема урока “ Логический тип данных в языке
программирования Pascal ”. Запишите тему урока.
II. Лекция
Вы уже знаете, что функционирование любой программы связано с обработкой данных.
Данные задаются обычно в начале программы. Программа по ходу выполнения может
запрашивать недостающие исходные данные.
В процессе выполнения программы исходные данные преобразуются в результаты.
Сегодня наша задача разобрать логический тип данных, как объявлять в программе, какие
значения этот тип имеет, какой результат может выдать. Из курса логики мы уже знаем,
высказывание может быть ложным (False) или истинным (true). Так вот логический тип
также тесно связан с понятием истина и ложь.
• Логический тип данных это множество, состоящее из двух величин,
расположенных в следующем порядке:False, True.
• Между ними истинно отношение: false, = , <>, <=, >=
Давайте теперь рассмотрим листинг программы на Turbo Pascal, которая выводит таблицы
истинности на логические операции.
Program logtabl;
Var A,B: boolean;
Begin writeln(‘A’, ‘B’, ‘not A’,’A and B’, ‘A or B’);
For A:= False to true do
For B:= False to true do
Writeln ( A:7, В:7, not A:7,
A and B:7, A or B:7)
end.
В системе программирования PascalABC программа Logtabl не выполняется, так как не
допускается использование логической переменной в качестве параметра в операторе
цикла FOR. С учетом такого ограничения составьте программу получения таблицы
истинности, аналогичную программе Logtabl, на Pascal ABC
Логические операцииNot (отрицание)And (коньюнкция)Or (дизьюнкция)Xor (исключающее или)Методические рекомендации к уроку составила: Дикарева А.С. Учитель информатики и ИКТ
МОУ «СОШ № 25 при МаГК» г. Магнитогорска
Пример решения задачи на PascalABC:
program logtabl;
var i : Integer;
a,b: Boolean;
begin
WriteLn('a b not a a and b a or b');
Writeln('');
i:=0;
repeat
a:=i mod 2 = 1; b:=i div 2 = 1;
WriteLn(a, b:8,
(not a):8, (a and b):8, (a or b):9);
i:=i+1;
until i>3;
end.
III. Подведение итогов урока
Учитель. На этом уроке вы узнали о логическом типе данных языка Pascal. Давайте
обобщим услышанное во время лекции.
Ответьте, пожалуйста, на вопросы:
1. Что такое логический тип (Ответ: это множество, состоящее из двух величин).
2. Переменные логического типа, описываются в каком разделе? С помощью какого
зарезервированного слова? (Ответ: Var, Boolean)
3. Основные операции с логическим типом (Ответ: NOT, AND, OR, XOR).
4. Приоритет логических операций (Ответ: Действия в скобках, умножение, деление,
сложение, вычитание, неравенства.)
Учитель. Большое всем спасибо за работу. Очень рада, что вы внимательно слушали,
помогали мне в работе. И теперь главное, хорошо подготовиться дома к следующему
занятию.
IV. Домашнее задание
1. Знать материал лекции.Методические рекомендации к уроку составила: Дикарева А.С. Учитель информатики и ИКТ
МОУ «СОШ № 25 при МаГК» г. Магнитогорска
2. Решить задачи на языке программирования Pascal.
• Даны три целых числа: A, B, C. Проверить истинность высказывания: «Число B
находится между числами A и C».
• Даны два целых числа: A, B. Проверить истинность высказывания: «Ровно одно
из чисел A и B нечетное.