Электронная таблица Microsoft Excel
Оценка 4.6

Электронная таблица Microsoft Excel

Оценка 4.6
doc
08.05.2020
Электронная таблица Microsoft Excel
4. Табличный процессор Microsoft Excel.doc

Как сцепить дату и текст?

    Предположим Вы решили сделать приветствие при открытии файла. Приветствие должно содержать следующий текст: "Привет! Сегодня 07.08.2011". Естественно, дата должна меняться ежедневно. Для этого в ячейку А1 вводим текст "Привет! Сегодня ", в ячейке А2 формулу

=СЕГОДНЯ()

В английской версии:

Code

=TODAY()



В ячейке В2 применяем формулу

Code

=СЦЕПИТЬ(A1;A2)

В английской версии:

Code

=CONCATENATE(A1,A2)


Но результат получается совсем не тот, на который Вы рассчитывали:


Функция СЕГОДНЯ() возвращает текущую дату. Сегодня (день написания статьи) 7-е августа 2011-го года, порядковый номер этой даты - 40762, именно он и красуется в нашей формуле (о том как Excel хранит даты и время читайте в статье Функции даты и времени.). Как перевести его в привычный нам формат? Для этого необходимо перевести порядковый номер даты из числового в текстовый формат, с помощью функции ТЕКСТ().

Code

=ТЕКСТ(A2;"ДД.ММ.ГГГГ")

В английской версии:

Code

=TEXT(A2,"DD.MM.YYYY")



Теперь остаётся только сцепить текст нашего приветствия и преобразованную дату

Готово!


Если Вы не хотите хранить на листе текст приветствия, текущую дату и пользоваться функцией СЦЕПИТЬ(), то есть альтернативное решение - можно использовать одну формулу, в которой одновременно как константа хранится текст приветствия, работает функция СЕГОДНЯ(), переводится в текст в нужном формате порядковый номер текущей даты и функция СЦЕПИТЬ() заменена знаком амперсанд "&":

Code

="Привет! Сегодня "&ТЕКСТ(СЕГОДНЯ();"ДД.ММ.ГГГГ")

В английской версии:

Code

="Привет! Сегодня "&TEXT(TODAY(),"DD.MM.YYYY")


 


Скачано с www.znanio.ru

Как сцепить дату и текст?

Как сцепить дату и текст?

Готово! Если Вы не хотите хранить на листе текст приветствия, текущую дату и пользоваться функцией

Готово! Если Вы не хотите хранить на листе текст приветствия, текущую дату и пользоваться функцией
Скачать файл