Лабораторная работа «Создание теста в EXCEL»
Оценка 5

Лабораторная работа «Создание теста в EXCEL»

Оценка 5
Лабораторные работы
doc
информатика
Взрослым
16.02.2020
Лабораторная работа «Создание теста в EXCEL»
Лабораторная работа «Создание теста в EXCEL»
Лабораторная работа «Создание теста в EXCEL».doc

Лабораторная работа «Создание теста в EXCEL»

Откройте электронную таблицу Excel_test_МХО.xls.

Вставьте новый лист и назовите его «Моя_проверка». На этом листе создайте таблицу (см. образец)

Образец

 

A

B

C

D

E

F

1

Задание

Эталон

Балл

 

Результаты опроса:

2

1

 

 

 

Фамилия

 

3

2

 

 

 

Группа

 

4

3

 

 

 

Результат

 

5

 

 

 

 

 

 

 

 

 

 

 

 

 

23

 

 

 

 

Критерии отметок

24

Сумма баллов

 

 

Доля

Отметка

25

Доля выполнения

 

 

0,51

3

26

Отметка

 

 

0,75

4

27

 

 

 

0,9

5

 

Задание: Необходимо создать лист проверки введенных данных и выставить отметку.

Ход выполнения:

Необходимо создать таблицу проверки введенных на листе Тест_демо ответов. Для этого используются эталоны правильных ответов, которые нужно ввести в столбец «Эталон». В тесте всего 5 заданий. Но, обратите внимание, общее количество вопросов в тесте – 12. Т.е. эталонов должно быть 12. В последнем задании (Задание № 5) важна именно последовательность правильных ответов, а не отдельные ответы.

Для подсчета баллов используется функция «ЕСЛИ».

Функция ЕСЛИ используется при проверке условий для значений и формул.

Возвращает одно значение, если заданное условие при вычислении дает значение ИСТИНА, и другое значение, если ЛОЖЬ.

Общий вид функции:

=ЕСЛИ(лог_выражение;значение_если_истина;значение_если_ложь)

пример:

=ЕСЛИ(Тест_демо!E10=Моя_проверка!B2;1;0) – проверка на эталонный ответ

Например, пусть введенный ответ на первый вопрос – 23, эталон правильного ответа – 26. Проверяем условие: совпадает ли введенный ответ с эталоном правильного ответа? Если совпадает, то в ячейке будет проставлена 1, если нет, то – 0.

 

Примеры остальных используемых функций и формул.

Для задания 5:

=ЕСЛИ(B13=Тест_демо!G54*10^5+Тест_демо!G55*10^4+Тест_демо!G56*10^3+Тест_демо!G57*10^2+Тест_демо!G58*10+Тест_демо!G59

=СУММ(C2:C23) – сумма баллов (подсчет набранных баллов)

=C24/12 – подсчет доли выполнения (C24 – сумма набранных баллов, 12 – кол-во заданий)

=ЕСЛИ(C25>=E27;5;ЕСЛИ(C25>=E26;4;ЕСЛИ(C25>=E25;3;2))) – выставление отметки

=ЕСЛИ(D63="да";Моя_проверка!C26;"") – вывод отметки

=Тест_демо!D4 – определение введенной фамилии и имени.

=Тест_демо!I4 – определение введенного номер группы

 

Создание списка ответов для вопроса одиночного выбора из списка:

Данные à Проверкаà Закладка «Параметры» à тип данных «Список» à в поле «источник» через точку запятой без пробелов ввести ответы, один из которых должен быть правильным.

(Для Office’2007: Закладка «Данные» àРаздел «Работа с данными» àКнопка «Проверка данных» Закладка «Параметры» à тип данных «Список» à…)


Лабораторная работа «Создание теста в

Лабораторная работа «Создание теста в
Скачать файл