Вычисления в таблицах
Оценка 4.7

Вычисления в таблицах

Оценка 4.7
Статья
08.06.2020

Вычисления в таблицах осуществляется с помощью формул. Формула хранится в ячейке и отображается в строке функций (fx-строке). Формула всегда начинается со знака «=» (равно).

Новый термин

Операнды – это элементы, над которыми производятся вычисление. Операторы – это действия, которые должны быть выполнены над операндами (рис. 26).

Рис. 26. Элементы формулы

В приложении МойОфис Таблица доступны четыре типа операторов:

  • Арифметические + (плюс), - (минус), * (умножение), / (деление), ^ (возведение в степень), % (вычисление доли в процентах), Текстовые, Операторы сравнения, Операторы ссылок.
  • Операторы сравнения = (равно), > (больше), < (меньше), >= (больше или равно),<= (меньше или равно), <> (не равно).
  • Текстовые операторы & (апмерсанд) соединение двух и более строк символов в непрерывную последовательность символов.
  • Операторы ссылок (Определяют ссылки на диапазоны, листы, ячейки) ! (определение ссылки на другой лист), : (определение ссылки на диапазон ячеек).

Примеры базовых математических операций

Пример выполнения сложения приведен на рис. 27.

Рис. 27. Пример математической операции сложения чисел

Пример вычитания (ячейки выделяем мышкой) – рис. 28.

Рис. 28. Операция вычитания чисел

Пример умножения (рис. 29).

Рис. 29. Умножение чисел

Деление (рис. 30).

Рис. 30. Операция деления

Возведение в степень (рис. 31).

Рис. 31. Пример записи операции возведения в степень

Порядок вычисления зависит от типа операций. Приоритет выполнения математический операций в порядке его убывания показан на рис. 32.

Рис. 32. Порядок выполнения математический операций в порядке его убывания

Функции

Каждая встроенная МойОфис Таблица функция — это заранее определенная формула, имеющая название. Ввод функций осуществляется со знака равно «=», а затем следует вводить название функции. Иначе говоря, функция состоит из названия функции и ее аргументов (ее входных данных). При составлении несложных формул можно обойтись без функций. Однако там, где требуется сложить множество чисел, например, таких: =A1+A2+A3+A4+A5+A6+A7+A8+A9+A10 следует использовать эквивалентную ей формулу =СУММ(A1:A10), то есть, функцию суммирования (СУММ) – рис. 33.

Рис. 33. Пример применение функции СУММ

Еще пример: предположим, что требуется найти наибольшее и наименьшее число в диапазоне A1:A10. Применяем функции МИН (рис. 34) и МАКС (рис. 35).

Рис. 34. Ищем минимальное число по диапазону

Рис. 35. Ищем максимальное число по диапазону

Полагаю, что теперь вы самостоятельно сможете применить функцию =СРЗНАЧ(A2:C7) для того, чтобы подсчитать среднее значение по диапазону ячеек от А2 до С7.

Бесплатно учителям.
Свидетельство СМИ.
Приз 150 000 руб. ежемесячно.
10 документов.