г. Брянск
Конспект урока по информатике
Подготовила :
Киреева Мария Альгимантасовна
Цели урока:
Ø образовательные:
1. овладение умениями и навыками осуществлять ввод и вывод значений элементов одномерного массива;
2. овладение умениями и навыками нахождения суммы и среднего арифметического элементов массива;
Ø развивающие:
1. развитие структурного мышления учащихся;
2. развитие познавательного интереса.
Ø воспитательные:
1. формирование умения применять на практике полученные знания;
2. воспитание чувства ответственности за результаты своего труда;
3. восприятие компьютера как инструмента обработки информации.
Формы организации учебной деятельности: индивидуальная, коллективная.
Формы работы: фронтальная, индивидуальная, самостоятельная работа
Оборудование: компьютер, мультимедийный проектор, интерактивная доска, презентация, интерактивная доска.
Раздаточный материал: тексты заданий для самостоятельной работы.
План урока:
1. Оргмомент. (1 мин)
2. Актуализация знаний. Самостоятельная работа (5 мин)
3. Постановка проблемной задачи. (2 мин)
4. Построение блок схемы. Запись алгоритма на языке Паскаль. (15 мин)
5. Практическая работа. (15 мин )
6. Подведение итогов. Домашнее задание (2 мин)
Ход урока
Деятельность учителя |
Деятельность учеников |
||||
1. Оргмомент. (1 мин) 2. Актуализация знаний. Самостоятельная работа (5 мин) |
|||||
-Здравствуйте ребята. Давайте вспомним, с чем мы познакомились на предыдущем уроке? - Что нового мы узнали?
-Сейчас будет небольшая самостоятельная работа. (Учитель раздает карточки с самостоятельной работой (см. приложение 1)) |
- с массивами.
- Что такое массив, виды массивов, генератор случайных чисел и как описывать массивы в Паскале, как заполнять массив. |
||||
3. Постановка проблемной задачи. (2 мин) |
|||||
Помните раньше мы решали задачи по подсчету суммы N элементов с помощью циклов. Давайте попробуем решить задачу с помощью массивов: «Мама попросила сходить в магазин за продуктами и дала список из 10 наименований. Составьте программу подсчета суммы всей покупки». -Расскажите, как бы вы выполнили бы это задание в жизни» (слайд 1).
- Попробуем провести аналогию с программой (слайд 4):
- Что из необходимых действий мы уже умеем делать? - А как посчитать сумму? Вспомните как мы это делали раньше с помощью циклов. -Также поступим и в этом случае. |
- дети пытаются предложить решения задачи, приходят к выводу, что необходимо ввести цены продуктов с клавиатуры и посчитать сумму.
- пришел в магазин, взял корзину для продуктов, заполнил корзину, на кассе расплатился, маме отдал чек и сдачу.
- Описывать массив и заполнять его.
- мы в цикле поочередно складывали элементы и записывали в переменную
|
||||
4. Построение блок схемы. Запись алгоритма на языке Паскаль. (15 мин) |
|||||
- Давайте попробуем построить блок-схему решения этой задачи
-Теперь давайте попробуем написать программу.
- А как можно оптимизировать решение этой задачи? Можно сократить количество циклов?
- Обратите внимание на операторные скобки. Зачем они нам здесь необходимы?
- Молодцы. А если мы захотим посчитать среднее арифметическое элементов массива, что надо будет добавить в эту программу.
|
Один учащийся строит блок-схему в программе «Конструктор блок-схем», остальные в тетради. Пример итоговой блок-схемы:
Var a:array [1..10] of integer; i, s: integer; Begin For i:= 1 to 10 do Read (a[i]); For i:= 1 to 10 do s:=s+a[i]; write (s); End.
Var a:array [1..10] of integer; i, s: integer; Begin For i:= 1 to 10 do begin Read (a[i]); s:=s+a[i]; write (s); end; End. - Потому что в цикле больше одного оператора.
-Надо будет добавить в раздел Var переменную sr типа real и в конце программы написать строчку sr:= s/10; |
||||
5. Практическая работа. (15 мин ) |
|||||
- Теперь садимся на компьютер и в среде Pascal ABC пробуем написать программу подсчета суммы и среднего арифметического элементов массива. Попробуйте усовершенствовать программу таким образом, чтобы: - элементы массива заполнялись случайными числами из диапазона [0;100]. |
|
||||
6. Подведение итогов и рефлексия. Домашнее задание (2 мин) |
|||||
Чему новому мы сегодня научились?
Учитель называет оценки за работу и раздает домашнее задание (слайд 6): Массив из 15 элементов заполнить случайными числами из диапазона [10;60]. Определить: - сумму элементов; - произведение элементов; -сумму квадратов всех элементов. - среднее арифметическое первых 6 элементов.
|
- Мы научились считать сумму и среднее арифметическое элементов массива. |
Список использованной литературы:
1. Златопольский Д.М. Сборник задачпо программированию- 2-е изд., перераб. и доп. – СПб.: БХВ-Петербург, 2007
2. Преподавание базового курса информатики в средней школе: Методическое пособие / И.Г. Семакин, Т.Ю. Шеина. – 2‐е изд., испр. и доп. – М.: БИНОМ. Лаборатория знаний, 2004. – 540 с.
Использованные материалы и Интернет-ресурсы
1. Программа «Конструктор алгоритмов» http://files.school-collection.edu.ru/dlrstore/fff3a9b4-5a73-445a-a617-624b63d4b8a6/9_14.exe
Приложение1:
ФИО ___________________________ Класс___________
1 вариант
1. Опишите массив целых чисел, состоящий из 15 элементов
2. Дан массив А=(1,5,-11,8,13,6,19,4). Определите чему равно:
A[1]=_____
A[2]+A[5]=_____
9*A[2]=_____
3*A[3]+A[8]=_____
3. С помощью датчика случайных чисел задайте диапазон:
a. [0;10] __________________
b. [-5;5] __________________
c. [10;20] __________________
ФИО ___________________________ Класс___________
2 вариант
1. Опишите массив вещественных чисел, состоящий из 11 элементов
2. Дан массив А=(0,8,17,-2,1,5,14). Определите чему равно:
A[6]=_____
A[3]+A[4]=_____
2*A[3]=_____
5*A[5]-A[2]=_____
3. С помощью датчика случайных чисел задайте диапазон:
a. [0;50] __________________
b. [-10;10] __________________
c. [30;40] __________________
Скачано с www.znanio.ru
© ООО «Знанио»
С вами с 2009 года.