Подготовка теста в MS Excel
Оценка 4.8

Подготовка теста в MS Excel

Оценка 4.8
Домашнее обучение
doc
информатика
10 кл
30.03.2018
Подготовка теста в MS Excel
1. Для текста заданий используйте информацию из Справки MS Excel. Ваш тест должен содержать не менее 10 вопросов, каждый вопрос предусматривать не менее 3 вариантов ответов. 2. Наберите вопросы и разместите варианты ответов, например: 3. Оформите выбор: в ячейке C4 (напротив первого вопроса) выделите ячейку, выберите пункт меню Данные→Проверка:1. Для текста заданий используйте информацию из Справки MS Excel. Ваш тест должен содержать не менее 10 вопросов, каждый вопрос предусматривать не менее 3 вариантов ответов. 2. Наберите вопросы и разместите варианты ответов, например: 3. Оформите выбор: в ячейке C4 (напротив первого вопроса) выделите ячейку, выберите пункт меню Данные→Проверка:
1_САМОСТОЯТЕЛЬНАЯ РАБОТА Тест в EXCEL.doc
Самостоятельная работа             Подготовка теста в     ms      Excel 1. Для текста заданий используйте информацию из Справки MS Excel. Ваш тест  должен содержать не менее 10 вопросов, каждый вопрос предусматривать не  менее 3 вариантов ответов. 2. Наберите вопросы и разместите варианты ответов, например: 3. Оформите выбор: в ячейке C4 (напротив первого вопроса) выделите ячейку,  выберите пункт меню Данные Проверка: → Из опций «Тип данных» нужно выбрать «список», после этого появится окно ввода  «Источник». Нажать на кнопку  , после чего выделить ячейки с ответами (в нашем  случае это  Теперь нажмите кнопку   и далее, на кнопку «ОК». Вы увидите, что около ячейки C4 имеется кнопка для выбора. Нажав ее, получите варианты. 4. Поместите в соседнюю ячейку (D4) функцию проверки. Самостоятельная работа  Смысл функции заключается в следующем: Если в тестируемой ячейке пусто, то в ячейку, содержащую функцию, тоже поместить  пусто (нет ответа–нет реакции). Иначе, если там не пусто, то (второй этап) Если ответ совпадает с верным (в д. с. из ячейки G4), то поместить  «да», иначе «нет». ПУСТО? ДА НЕТ ПУСТО ВЕРНО? ДА ДА НЕТ НЕТ В схеме знак вопроса показывает отношение к ячейке с выбором. Пусто ли, верно ли в  ячейке C4. Значение с реакцией будет находиться в D4. Аналогично стройте вопросы и ответы, копируйте функцию и не забывайте менять  адрес ячейки с правильным ответом в функции. В частности, во втором вопросе у вас  ответ G5, но могло бы быть и G6. 5. Чтобы посчитать число верных ответов, надо ввести функцию СЧЕТЕСЛИ =СЧЕТЕСЛИ(D4:D5; “да”) Функция даст столько баллов, сколько раз слово «да» встретилось в ячейках с D4 по  D5, в конкретном случае ячеек может быть больше. 6. Такого рода тест можно расценить как построенный по модели Скиннера­ Краудера, то есть с прямой оценкой но произвольным порядком вопросов. Кроме  того, учащийся путем перебора может узнать правильный ответ. «Продвинутый»  учащийся может просто рассмотреть функцию проверки. Очевидно, роль такого теста скорее закрепляюще­тренирующая, нежели  контролирующая. Однако придать тесту подобие строгости можно. Для этого нужно: 1). с помощью меню Формат лишить защиты те ячейки, в которые вносится ответ и  реакция, а также подсчет баллов: Самостоятельная работа  2). выделить заголовки столбцов, в ячейках которых имеются ответы и Формат­ Скрыть их. Можно также скрыть формулы. Затем (Сервис) защитить лист.  Окончательно, при сохранении файла можно задать пароль на изменения (нажав  Сервис­Общие параметры) Самостоятельная работа  Примечания. Примечания. 1. Для большего разнообразия форм выбора ответа можно воспользоваться Элементами Управления (форма). В этом случае: А) выводим панель Формы  Б) Выбираем, например, элемент Список (выделенный на рисунке) В) Щелкаем по нему правой кнопкой мыши и выбираем Формат Г) Заполняем поля: Диапазон должен быть вертикальным списком ответов В ячейку, с которой установлена связь, будет помещен номер выбранного ответа. В отличие от метода с меню Данные­Проверка, можно разместить варианты ответов на отдельном листе. Ссылка на диапазон будет типа Лист2!$C$14:$D$16 После этого с помощью меню  скрыть лист с ответами (предварительно щелкнув по его ярлычку) Наконец, финальная стадия – защита книги. Это позволит запретить отображение  листа. 2. Чтобы исключить возможность повторного выбора (однократный тест), следует  воспользоваться аппаратом Visual Basic. Это превратит тест в из тренировочного в  контрольный. На VB­проект ставится защита. Для пользования макросами следует задать  низкий уровень безопасности и перезапустить приложение. отметка плохо 3. О принятии решения ЕСЛИ в случаях многократной проверки. Сопоставим таблице оценок нужную функцию: балл 0 1 2 3 4 5 6 7 8 Значит, <3 (0, 1, 2) т. е. плохо нормально здорово >=3? >=6? Вывод:  =ЕСЛИ(A1="";"";ЕСЛИ(A1>=3;ЕСЛИ(A1>=6;"Здорово";"Норма");"Плохо")) Значит, <6 (3, 4, 5) т. е. норма Значит,  (6, 7, 8) т. е.

Подготовка теста в MS Excel

Подготовка теста в MS Excel

Подготовка теста в MS Excel

Подготовка теста в MS Excel

Подготовка теста в MS Excel

Подготовка теста в MS Excel

Подготовка теста в MS Excel

Подготовка теста в MS Excel
Скачать файл