Проверь себя!
Что такое массив?
Напишите команду вывода на экран шестого элемента массива А.
Оператор цикла с предусловием в Паскале?
Напишите описания значений массива А, состоящего из пяти элементов в Паскале?
Оператор цикла с параметром в Паскале?
Проверь себя!
Массив – это упорядоченная последовательность, состоящая из фиксированного количества величин одного типа.
write ( А[6] )
wile ____________ do
var A : array[ 1 .. 5 ] of integer
For i:= ___ to ____do
Строки в Паскале
Строка - это последовательность символов.
Длина строки - количество символов в строке.
(Диапазон от 0 до 255)
Строковая константа – последовательность символов заключенная в апострафы.
Пример: ` Офицер `
`23456`
`Институт МВД `
Строковая переменная
var <идентификатор>: string [<максимальная длина строки >]
var name: string[20]
var slovo: string - максимальное величина длины строки
Строковая переменная занимает в памяти на 1 байт больше, чем указанная в описании длина. (Нулевой байт содержит значение текущей длины строки).
Каждый отдельный символ обозначается именем строки с индексом
name [2] ; name [9]; name [i]
Операция сцепления (+)
Операции отношения
Функция Copy
Функция Length
Процедура Delete
Процедура Insert
Стандартные операции, процедуры и функции.
Операция сцепления (+)
`Полицейский ` + ` всегда` + ` на страже ` + `порядка`
получиться строка
`Полицейский всегда на страже порядка`
Операции отношения (<, <=, >, >=, =, <>)
Выполняется сравнение двух строк (слева направо до первого несовпадающего символа, та строка считается больше, в которой первый несовпадающий символ имеет больший номер в таблице кодировки).
Стандартные процедуры и функции.
Функция Copy (S, Poz, N)
Выделяет из строки S подстроку длиной N символов, начиная с позиции Poz.
N и Poz - целочисленные выражения
Значение S | Выражение | Результат |
` КРЕМВДУК ` | Copy (S,4,3) | |
` КРЕМВДУК ` | Copy (S,1,4) + `ЛЬ ` |
Значение S | Выражение | Результат |
` КРЕМВДУК ` | Copy (S,4,3) | ` МВД ` |
` КРЕМВДУК ` | Copy (S,1,4) + `ЛЬ ` |
Значение S | Выражение | Результат |
` КРЕМВДУК ` | Copy (S,4,3) | ` МВД ` |
` КРЕМВДУК ` | Copy (S,1,4) + `ЛЬ ` | `КРЕМЛЬ` |
Стандартные процедуры и функции.
Функция Length (S)
Определяет текущую длину строки S.
Результат – значение целого типа.
Значение S | Выражение | Результат |
` ПОЛИЦИЯ ` | Length (S) | |
` СЛУЖБА ` | Length (S) |
Значение S | Выражение | Результат |
` ПОЛИЦИЯ ` | Length (S) | 7 |
` СЛУЖБА ` | Length (S) |
Значение S | Выражение | Результат |
` ПОЛИЦИЯ ` | Length (S) | 7 |
` СЛУЖБА ` | Length (S) | 6 |
Стандартные процедуры и функции.
Процедура Delete (S, Poz, N)
Удаляет N символов из строки S, начиная с позиции Poz.
Исходное значение S | Оператор | Конечное значение S |
` УПРНЕРА ` | Delete (S,2,4) | |
` МИГАКУВР ` | Delete (S,3,5) |
Исходное значение S | Оператор | Конечное значение S |
` УПРНЕРА ` | Delete (S,2,4) | `УРА ` |
` МИГАКУВР ` | Delete (S,3,5) |
Исходное значение S | Оператор | Конечное значение S |
` УПРНЕРА ` | Delete (S,2,4) | `УРА ` |
` МИГАКУВР ` | Delete (S,3,5) | `МИР` |
Стандартные процедуры и функции.
Процедура Insert (S1, S2, Poz)
Вставляет строку S1 в строку S2, начиная с позиции Poz
Исходное значение S2 | Оператор | Конечное значение S |
`Рис. 2 ` | Insert (N, S2, 6) |
Исходное значение S2 | Оператор | Конечное значение S |
`Рис. 2 ` | Insert (N, S2, 6) | `Рис. N 2 ` |
Составить программу, которая запрашивает слово и определяет количество символов в нем.
Program zadaha;
var a: string;
S: integer;
begin
write ( `введите слово`);
readln (а);
S:= Length (а);
writeln (`в слове`, a ,` `S, `символов`)
end.
Пример 1. Сформировать строку из n звездочек, (n - целое число , 1 ≤ n ≥ 255).
Program Stars;
var a: string;
n, i: integer;
begin
write (`введите число звездочек`);
readln (n);
a:=` `;
for i:=1 to n do
a:=a+` * `;
writeln (a)
end.
Пример 2. Получить из слова «ВЕЛИЧИНА» слово «НАЛИЧИЕ».
Program Slovo_1;
var Sl1, Sl2 : string [10];
begin
Sl1 := `ВЕЛИЧИНА`
Sl2 := copy ( Sl1,7,2) + copy ( Sl2,3,4) + Sl1[2];
writeln (Sl2)
end.
Пример 3: Известно, что фамилия подозреваемого в совершении преступления начинается на букву «С». Необходимо определить количество подозреваемых, если в списке всего 32 фамилии.
program z3;
Материалы на данной страницы взяты из открытых источников либо размещены пользователем в соответствии с договором-офертой сайта. Вы можете сообщить о нарушении.