Исполнитель Черепаха рисует геометрические фигуры в Кумире с использованием циклического алгоритма
Оценка 4.9

Исполнитель Черепаха рисует геометрические фигуры в Кумире с использованием циклического алгоритма

Оценка 4.9
Компьютерные программы +3
ppt
информатика +1
6 кл—7 кл
26.04.2020
Исполнитель Черепаха рисует геометрические фигуры в Кумире с использованием циклического алгоритма
Исполнитель Черепаха рисует геометрические фигуры в Кумире с использованием циклического алгоритма
Черепаха цикл.ppt

Исполнитель Черепаха рисует геометрические фигуры в

Исполнитель Черепаха рисует геометрические фигуры в

Исполнитель Черепаха рисует геометрические фигуры в Кумире с использованием циклического алгоритма

Циклический алгоритм Циклический алгоритм - это описание повторяющихся действий

Циклический алгоритм Циклический алгоритм - это описание повторяющихся действий

Циклический алгоритм

Циклический алгоритм - это описание повторяющихся действий.
Список повторяющихся действий называется телом цикла.
В общем виде конструкция повторения записывается
нц <число повторений> раз
<тело цикла>
кц

Черепаха алг Квадрат нач вперед(100) вправо(90) вперед(100) вправо(90) вперед(100) вправо(90) вперед(100) вправо(90) кон

Черепаха алг Квадрат нач вперед(100) вправо(90) вперед(100) вправо(90) вперед(100) вправо(90) вперед(100) вправо(90) кон

использовать Черепаха
алг Квадрат
нач
вперед(100)
вправо(90)
вперед(100)
вправо(90)
вперед(100)
вправо(90)
вперед(100)
вправо(90)
кон

Черепаха рисует квадрат. Второй способ (вспомогательный алгоритм)

использовать Черепаха
алг Квадрат
нач
Сторона и угол
Сторона и угол
Сторона и угол
Сторона и угол
кон
алг Сторона и угол
нач
вперед(100)
вправо(90)
вперед(100)
вправо(90)
вперед(100)
вправо(90)
вперед(100)
вправо(90)
кон

Черепаха рисует квадрат. Первый способ (линейный алгоритм)

Блок-схема циклического алгоритма

Блок-схема циклического алгоритма

Блок-схема циклического алгоритма. Черепаха рисует квадрат

Заголовок цикла

Черепаха алг Квадрат нач нц 4 раз вперед(100) вправо(90) кц кон

Черепаха алг Квадрат нач нц 4 раз вперед(100) вправо(90) кц кон

использовать Черепаха
алг Квадрат
нач
нц 4 раз
вперед(100)
вправо(90)
кц
кон

Черепаха рисует квадрат. Четвертый способ (циклический+вспомогательный алгоритмы)

использовать Черепаха
алг Квадрат
нач
нц 4 раз
Сторона и угол
кц
кон

алг Сторона и угол
нач
вперед(100)
вправо(90)
кон

Черепаха рисует квадрат. Третий способ (циклический алгоритм)

Правильный многоугольник Правильный многоугольник - это многоугольник, у которого все стороны и углы равны

Правильный многоугольник Правильный многоугольник - это многоугольник, у которого все стороны и углы равны

Правильный многоугольник

Правильный многоугольник - это многоугольник, у которого все стороны и углы равны

Треугольник Сумма углов треугольника равна 180°

Треугольник Сумма углов треугольника равна 180°

Треугольник

Сумма углов треугольника равна 180°.
Т.к. треугольник правильный, то каждый его угол равен 60° (180°:3=60 °).
Развернутый угол равен 180°.
На рис. ∠АСО – развернутый. Нам нужно найти угол поворота Черепашки влево (Черепашка стоит в вершине С, смотрит вперед), т. е. вычислить ∠ОСВ (∠ОСВ=∠АСО- ∠АСВ; ∠ОСВ=180°-60°=120°)

Найдем закономерность Многоугольник

Найдем закономерность Многоугольник

Найдем закономерность

Многоугольник

Количество сторон многоугольника

Внешний угол поворота Черепашки

Квадрат

4

90°

Треугольник

3

120°

Градусная мера окружности
равна 360°

Формула вычисления внешнего угла правильного многоугольника

Формула вычисления внешнего угла правильного многоугольника

Формула вычисления внешнего угла правильного многоугольника


При рисовании правильного многоугольника необходимо поворачивать Черепашку на угол, который можно вычислить по формуле
Угол = 360°:К,
где К – количество углов многоугольника.
Таким образом, для построения пятиугольника угол, на который нужно повернуться Черепашке, равен 360°:5=72°.

Черепаха алг Окружность нач нц 360 раз вперед(1) вправо(1) кц кон

Черепаха алг Окружность нач нц 360 раз вперед(1) вправо(1) кц кон

использовать Черепаха
алг Окружность
нач
нц 360 раз
вперед(1)
вправо(1)
кц
кон

Если менять количество повторений и градус поворота, то можно получить разные узоры

использовать Черепаха
алг Полуокружность
нач
нц 180 раз
вперед(1)
вправо(1)
кц
кон

использовать Черепаха
алг Петля
нач
нц 180 раз
вперед(1)
вправо(1)
кц
вправо(90)
нц 180 раз
вперед(1)
вправо(1)
кц
кон

Задания для самостоятельного выполнения

Задания для самостоятельного выполнения

Задания для самостоятельного выполнения

Решение для задач самостоятельного выполнения

Решение для задач самостоятельного выполнения

Решение для задач самостоятельного выполнения

Источники информации: Информатика: учебник для 6 класса/

Источники информации: Информатика: учебник для 6 класса/

Источники информации:

Информатика: учебник для 6 класса/ Л.Л. Босова, А.Ю. Босова.- М.: БИНОМ. Лаборатория знаний, 2014.
Информатика. Изучаем алгоритмику. МойКуМир.5-6 классы/Е.А. Мирончик, И.Д. Куклина, Л.Л. Босова. – М.: БИНОМ. Лаборатория знаний, 2018.
https://uventa-shop.ru/543-thickbox_default/0336410360.jpg - изображение транспортира.
https://www.math10.com/ru/geometria/geogebra/fullscreen.html - бесплатное он-лайн геометрическое приложение для рисования геометрических фигур.

Материалы на данной страницы взяты из открытых истончиков либо размещены пользователем в соответствии с договором-офертой сайта. Вы можете сообщить о нарушении.