Презентация к уроку информатики "Программирование линейных алгоритмов"
Оценка 4.6
Презентации учебные
ppt
информатика
9 кл
22.04.2017
Что такое алгоритм?
В какой форме записываются алгоритмы?
Какие типы алгоритмов вы знаете?
Какие основные операторы языка Pascal вы знаете?
Как называется алгоритм, у которого команды выполняются друг за другом?
Программирование
линейных алгоритмов. Решение задач.
Цель урока:
повторить,
обобщить,
закрепить знания, полученных по теме «Программирование линейных алгоритмов».
Последовательность построения линейного алгоритма:
1) Ввод исходных данных.
2) Получение промежуточных данных, искомых результатов.
3) Вывод искомого результата.
Программирование линейных алгоритмов).ppt
Презентация к уроку информатики "Программирование линейных алгоритмов"
Зорина Ольга
Александровна
Учитель информатики
МБОУ «СШ №7»
Что такое
В какой
Что такое алгоритм
алгоритм??
В какой форме
алгоритмы?
алгоритмы?
форме записываются
записываются
Какие Какие типы алгоритмов
типы алгоритмов вы знаете
вы знаете??
Какие
Какие основные операторы
основные операторы языка
языка
Pascal вы знаете?
вы знаете?
Pascal
Как называется
Как называется алгоритм
которого команды выполняются
которого команды выполняются
друг за другом?
друг за другом?
алгоритм, у
, у
Презентация к уроку информатики "Программирование линейных алгоритмов"
Презентация к уроку информатики "Программирование линейных алгоритмов"
Цель урока:
Цель урока:
повторить
повторить, ,
обобщить
обобщить,,
закрепить
закрепить знания,
знания,
полученных по теме
полученных по теме
«Программирование линейных
«Программирование линейных
алгоритмов».
алгоритмов».
Презентация к уроку информатики "Программирование линейных алгоритмов"
Последовательность построения
Последовательность построения
линейного алгоритма: :
линейного алгоритма
1)1)ВводВвод исходных данных.
исходных данных.
2)2)Получение
Получение
промежуточных данных
данных, ,
промежуточных
искомых результатов
результатов..
искомых
Вывод искомого
искомого
результата.
результата.
3)3) Вывод
Презентация к уроку информатики "Программирование линейных алгоритмов"
Program z2;;
Program z2
Var a,b,s: real;
Var a,b,s: real;
Begin
Begin
Введи катеты’);’);
Writeln (‘Введи катеты
Writeln (‘
Readln (a,b);
Readln (a,b);
s:=1/2*a*b;
s:=1/2*a*b;
Writeln (‘s=’,s);
Writeln (‘s=’,s);
Readln;
Readln;
EndEnd..
Презентация к уроку информатики "Программирование линейных алгоритмов"
Задача №1. Написать программу нахождения
. Написать программу нахождения
Задача №1
расстояния между двумя точками.
расстояния между двумя точками.
Координаты точек известны (х1, у1), (х2, у2).
Координаты точек известны (х1, у1), (х2, у2).
1) Математическая модель.
1) Математическая модель.
Ввести х1, у1, х2, у2
Ввести х1, у1, х2, у2
r
Вывести rr
Вывести
2
y
1
x
2
x
1
y
2
2
Презентация к уроку информатики "Программирование линейных алгоритмов"
2) 2) Блоксхема алгоритма
Презентация к уроку информатики "Программирование линейных алгоритмов"
3) Программа на языке
3) Программа на языке
Паскаль
Паскаль
Program rastojanie;
rastojanie;
Program
Uses crt;crt;
Uses
Var Var x1, y1, x2, y2:
Real;
r: r: Real;
Begin
Begin
Integer;
x1, y1, x2, y2: Integer;
Read (x1, y1, x2, y2);
(x1, y1, x2, y2);
Read
r:= Sqrt(Sqr(x2x1) + Sqr(y2y1));
r:= Sqrt(Sqr(x2x1) + Sqr(y2y1));
Write Write (r);
(r);
End.End.
Презентация к уроку информатики "Программирование линейных алгоритмов"
Презентация к уроку информатики "Программирование линейных алгоритмов"
Задача №2. Найти число а, если
. Найти число а, если
Задача №2
известно, что х% числа – это bb..
известно, что х% числа – это
1) Математическая модель
1) Математическая модель
Ввести xx, , bb
Ввести
aa = (100*
= (100*bb)/)/xx
Вывести a a
Вывести
Презентация к уроку информатики "Программирование линейных алгоритмов"
2) Блоксхема алгоритма.
2) Блоксхема алгоритма.
Презентация к уроку информатики "Программирование линейных алгоритмов"
3) Программа на языке
3) Программа на языке
Паскаль
Паскаль
Program procent
procent;;
Program
Uses crt;crt;
Uses
Var Var x, b:Integer;
x, b:Integer;
аа:Real;
:Real;
Begin
Begin
Read (x,b);
(x,b);
Read
a := (100*b)/x;
a := (100*b)/x;
Write Write (a);
(a);
EndEnd..
Презентация к уроку информатики "Программирование линейных алгоритмов"
Домашнее задание:
Домашнее задание:
1)1) Даны два числа х и у. Найти их
Даны два числа х и у. Найти их
и
среднее
среднее
и
среднее геометрическое..
среднее геометрическое
арифметическое
арифметическое
2) Дана сторона равностороннего
2) Дана сторона равностороннего
треугольника а. Найти его
треугольника а. Найти его
радиус вписанной и
площадь SS, , радиус вписанной
и
площадь
описанной окружностей..
описанной окружностей
Презентация к уроку информатики "Программирование линейных алгоритмов"
Какова
Какова тематема нашего урока?
нашего урока?
Как вы считаете,
Как вы считаете, достигнута
достигнута
ли цель урока? Каким образом?
урока? Каким образом?
ли цель
Какие
операторы включают в
включают в
линейные программы? ?
линейные программы
Назовите
Назовите
Назовите операторы ввода
операторы ввода??
Назовите операторы вывода
операторы вывода??
Какие операторы
Материалы на данной страницы взяты из открытых истончиков либо размещены пользователем в соответствии с договором-офертой сайта. Вы можете сообщить о нарушении.