Презентация по информатике на тему "Знакомство с языком Паскаль" (информатика, средняя школа)

  • Презентации учебные
  • ppt
  • 06.03.2018
Публикация на сайте для учителей

Публикация педагогических разработок

Бесплатное участие. Свидетельство автора сразу.
Мгновенные 10 документов в портфолио.

Презентация "Знакомство с языком программирования Паскаль" будет помощником при изучении языка программирования Паскаль в средней школе. В ней рассмотрены основные моменты по структуре программы, разобраны примеры перевода с математического языка на язык программирования и основная ключевая задача обмена значениями двух переменных.Презентация для средней школы по информатике "Знакомство с языком Паскаль".
Иконка файла материала знакомство с Паскалем.ppt
Знакомство с Знакомство с Знакомство с Знакомство с языком Паскаль языком Паскаль языком Паскаль языком Паскаль
Паскаль - это универсальный язык программирования, позволяющий решать самые разнообразные задачи обработки информации. Оператор - команда алгоритма, записанную на языке программирования.
Раздел описания переменных начинается со слова Vаr. В стандарте языка Паскаль существуют два числовых типа величин: вещественный и целый. Слово integer обозначает целый тип. Вещественный тип обозначается словом real.
Ввод исходных данных с клавиатуры происходит по оператору read (читать) или readln (читать строку): rеаd (<список переменных>); или rеаdln (<список переменных>);
Арифметический оператор присваивания на Паскале имеет следующий формат: <числовая переменная>:= <арифметическое выражение>
Вывод результатов происходит по оператору write (write - писать) или writeln (write line - писать в строку): writе (<список вывода>); или writеln (<список вывода>); 6
Математическое выражение А2 + B2 - 12С на Паскале записывается так: А*А + В*В - 12*С Это же выражение можно записать иначе: SQR(A) + SQR(B) - 12*С 7
Пример порядка вычисления арифметического выражения: 1 4 2 5 3 А * А + В * В - 12 * С 6 1 3 2 4 5 А + ((С - D) / (2 + К) - l)*B 8
Точка с запятой (;) ставится в конце заголовка программы, в конце раздела описания переменных, является разделителем операторов. Перед словом end точку с запятой можно не ставить. 9
Запятая (,) является разделителем элементов во всевозможных списках: списке переменных в разделе описания, списке вводимых и выводимых величин. 10
Комментарий - это пояснение к программе, которое записывается в фигурных скобках. 11
Program obmen; {заголовок программы} Var X,Y,Z:integer;{описание переменных} Begin {начало раздела операторов} readln (X,Y,Z); {ввод} Z:=X; {3-му присваиваем значение1-го} X:=Y; {1-му – 2-го} Y:=Z; {2-му – 3-го} Writeln (X,Y); {вывод} end. {конец раздела операторов}