Блок уроков: Табличный процессор Excel
Оценка 4.9 (более 1000 оценок)

Блок уроков: Табличный процессор Excel

Оценка 4.9 (более 1000 оценок)
doc
26.02.2020
Блок уроков: Табличный процессор Excel
Блок уроков.doc

Блок уроков: Табличный процессор Excel.
Урок . Решение биквадратного уравнения в EXCEL. 

1. Постановка задачи.

    Уравнение вида: ax4 + bx2 + c = 0, где a, b, c - любые действительные числа, называется биквадратным.

    Требуется найти такие значения переменной величины x, которые обращают уравнение в верное равенство.

2. Алгоритм решения биквадратного уравнения.

    Изложим основные пункты алгоритма решения биквадратного уравнения:

  1.     Прежде всего сделаем замену y = x2. Получим квадратное уравнение ay2 + by + c = 0. 
        Решим полученную систему квадратных уравнений.

           y = x2
           ay2 + by + c = 0.

        Начнем с решения квадратного уравнения.
        Далее в зависимости от значения переменной y будем решать второе уравнение y=x2 и находить значения переменной x.
  2.     С этой целью первым делом вычислим дискриминант квадратного уравнения: d = b2 - 4ac.
        Далее в зависимости от значения дискриминанта d и от значений переменной y могут встретиться следующие случаи:
    • Случай 1: Если d<0, то действительных решений нет.
    •                Если d>=0, то вычислим 

      Описание: http://sch35-k.h14.ru/informatika/teacher01/excel/les00.files/ris01.gif

 

    • Случай 2: Если d>=0 и y1<0 и y2<0, то действительных решений нет
    • Случай 3: Если d>=0 и y1>=0 и y2>=0, то получим 4 решения биквадратного уравнения:

      Описание: http://sch35-k.h14.ru/informatika/teacher01/excel/les00.files/ris02.gif 
    • Случай 4: Если d>=0 и y1>=0 и y2<0, то получим 2 решения биквадратного уравнения:

      Описание: http://sch35-k.h14.ru/informatika/teacher01/excel/les00.files/ris03.gif 
    • Случай 5: Если d>=0 и y2>=0 и y1<0, то получим 2 решения биквадратного уравнения:

      Описание: http://sch35-k.h14.ru/informatika/teacher01/excel/les00.files/ris04.gif 

2. Блок-схема алгоритма решения биквадратного уравнения.

    Ниже на рисунке показана блок-схема решения биквадратного уравнения: 

Описание: http://sch35-k.h14.ru/informatika/teacher01/excel/les00.files/shema.gif 

3. Проект решения биквадратного уравнения в Excel.

    Ниже на рисунке показан проект решения задачи отыскания корней биквадратного уравнения. 

Описание: http://sch35-k.h14.ru/informatika/teacher01/excel/les00.files/ris02.jpg 

    Опишем действия, необходимые для того, чтобы составить проект решения задачи в Excel.

  1.     В ячейку A1 записать наименование задачи: Решение биквадратного уравнения ax4 + bx2 + c = 0.
  2.     Вторую строку пропустить.
  3.     В третьей строке указать заголовки столбцов: № п/п; a= ; b= ; c= ; d= ; y1 ; y2 ; x1= ; x2= ; x3= ; x4= ;
  4.     Начиная с 4-ой строки, будем располагать матрицу с числовыми значениями коэффициентов a, b, c исходной задачи и необходимые формулы для вычисления значений расчетных величин: d, y1, y2, x1, x2, x3, x4:
    • В ячейку E4 поместить формулу для вычисления d
      =C4*C4 - 4B4*D4 и нажать клавишу Enter.
    • В ячейку F4 поместить формулу для вычисления y1
      =ЕСЛИ(E4<0;"решений нет";(-C4-КОРЕНЬ(E4))/(2*B4)) и нажать клавишу Enter.
    • В ячейку G4 поместить формулу для вычисления y2
      =ЕСЛИ(E4<0;"решений нет";(-C4+КОРЕНЬ(E4))/(2*B4)) и нажать клавишу Enter.
    • В ячейку H4 поместить формулу для вычисления x1
      =ЕСЛИ(E4<0;"решений нет";ЕСЛИ(И(F4<0;G4<0);"решений нет";ЕСЛИ(И(F4>=0;G4>=0);-КОРЕНЬ(F4);
      ЕСЛИ(И(F4>=0;G4<0);-КОРЕНЬ(F4);-КОРЕНЬ(G4))))) 
      и нажать клавишу Enter.
    • В ячейку I4 поместить формулу для вычисления x2
      =ЕСЛИ(E4<0;"решений нет";ЕСЛИ(И(F4<0;G4<0);"решений нет";ЕСЛИ(И(F4>=0;G4>=0);+КОРЕНЬ(F4);
      ЕСЛИ(И(F4>=0;G4<0);+КОРЕНЬ(F4);+КОРЕНЬ(G4))))) 
      и нажать клавишу Enter.
    • В ячейку J4 поместить формулу для вычисления x3
      =ЕСЛИ(E4<0;"решений нет";ЕСЛИ(И(F4<0;G4<0);"решений нет";ЕСЛИ(И(F4>=0;G4>=0);-КОРЕНЬ(G4);
      ЕСЛИ(И(F4>=0;G4<0);"решений нет";"решений нет")))) 
      и нажать клавишу Enter.
    • В ячейку K4 поместить формулу для вычисления x4
      =ЕСЛИ(E4<0;"решений нет";ЕСЛИ(И(F4<0;G4<0);"решений нет";ЕСЛИ(И(F4>=0;G4>=0);+КОРЕНЬ(G4);
      ЕСЛИ(И(F4>=0;G4<0);"решений нет";"решений нет")))) 
      и нажать клавишу Enter.
  5.    Проект решения задачи вычисления корней биквадратного уравнения ax4 + bx2 + c = 0 получен.
    Остается опробовать его или, как говорят программисты, отладить полученный проект. 
    Поместим в таблицу Excel матрицу с коэффициентами a, b, c следующих пяти исходных биквадратных уравнений: 

       8x4 - 6x2 + 200 = 0 
         x4 + 5x2 + 6 = 0 
         x4 - 5x2 + 6 = 0 
         x4 + x2 - 6 = 0 
         x4 - x2 - 6 = 0 


        Здесь предусмотрены все пять случаев, которые могут встретиться при решении биквадратного уравнения, изложенных подробно в разделе: "Алгоритм решения биквадратного уравнения". На рисунке выше коэффициенты указанных уравнений введены в таблицу Excel. Их Вы видите в соответствующих столбцах "a=", "b=", "c=" названной таблицы.
        Остается выравнять по длине документа название проекта, данное в ячейке A1 первой строки: "Решение биквадратного уравнения ax4 + bx2 + c = 0". Это можно сделать, если вначале выделить данное название по длине документа и затем нажать кнопку с буквой "а" посередине и стрелками справа, слева, сверху и снизу: Описание: http://sch35-k.h14.ru/informatika/teacher01/excel/les00.files/kn01.jpg 
        Помимо того, нужно четко показать столбцы и строки таблицы. Воспользуйтесь для этого командами выделения границ, представленными ниже нарисунке: 

    Описание: http://sch35-k.h14.ru/informatika/teacher01/excel/les00.files/gr.jpg.

Скачано с www.znanio.ru

Блок уроков: Табличный процессор

Блок уроков: Табличный процессор

Случай 4: Если d>=0 и y 1 >=0 и y 2 <0, то получим 2 решения биквадратного уравнения:

Случай 4: Если d>=0 и y 1 >=0 и y 2 <0, то получим 2 решения биквадратного уравнения:

Ниже на рисунке показана блок-схема решения биквадратного уравнения: 3

Ниже на рисунке показана блок-схема решения биквадратного уравнения: 3

В ячейку A1 записать наименование задачи:

В ячейку A1 записать наименование задачи:

Здесь предусмотрены все пять случаев, которые могут встретиться при решении биквадратного уравнения, изложенных подробно в разделе: "Алгоритм решения биквадратного уравнения"

Здесь предусмотрены все пять случаев, которые могут встретиться при решении биквадратного уравнения, изложенных подробно в разделе: "Алгоритм решения биквадратного уравнения"
Скачать файл
сегодня при записи на курсы переподготовки
для учителей