Лабораторная работа № 2 Лист Заказы
Оценка 4.6

Лабораторная работа № 2 Лист Заказы

Оценка 4.6
docx
17.11.2021
Лабораторная работа № 2 Лист Заказы
Л2-001756.docx

Лабораторная работа № 2

Лист Заказы

1.  Переименуйте рабочий лист ЛистЗ на имя Заказы.

2.     Введите в первую строку следующие данные, которые будут в дальнейшем именами полей:
А1 Þ Месяц заказа, В1 Þ Дата заказа, С1 Þ  Номер заказа, D1 Þ Номер товара, Е1 Þ  Наименование  товара, F1Þ Количество, G1 Þ Цена за ед., H1Þ Код фирмы заказчика., I1 Þ Название фирмы заказчика, J1 Þ Сумма заказа, К1 Þ Скидка(%), L1 ÞОплачено всего.

3.          Для первой строки выполните выравнивание данных по центру Формат Þ ЯчейкиÞВыравниваниеÞпереносить по словам.

4.          Выделите по очереди  столбцы B, C, D, E, F, G, H, I, J, K, L  и введите в поле имени имена Дата, Заказ, Номер2, Товар2, Количество, Цена2, Код2, Фирма2, Сумма, Скидка2 и Оплата.

5.          Выделите столбец В и выполните команду меню Формат Þ Ячейки. Во вкладке Число выберите
Числовой формат Дата, а в поле    Тип выберите формат вида ЧЧ.ММ.ГГ. В завершении диалога
щелкните кнопку ОК.

6.           Выделите столбцы G, J, L и выполните команду меню Формат Þ Ячейки. Во вкладке Число
выберите Числовой формат Денежный, укажите Число десятичных знаков равное 0, а в поле
Обозначение выберите $ Английский (США). В завершении диалога щелкните кнопку ОК.

7.     Выделите столбец К и выполните команду меню Формат Þ Ячейки. Во вкладке Число выберите
Числовой  формат Процентныйукажите  Число десятичных знаков  равное 0.  В  завершении
диалога щелкните кнопку ОК.

8.     В  ячейке А2 нужно набрать следующую формулу:

=ЕСЛИ(ЕПУСТО($В2);« »;ВЫБОР(МЕСЯЦ($В2);«Январь»;«Февраль»; «Март»; «Апрель»;«Май»;«Июнь»;«Июль»;«Август»;«Сентябрь»;«Октябрь»;«Ноябрь»;«Декабрь»))      (3.1)

И залить ячейку в желтый цвет.

Формула (3.1) работает следующим образом, вначале проверяется условие на пустоту ячейки А2. Если ячейка пусто, то ставится пробел, в противном случае с помощью функции ВЫБОР выбираем нужный месяц из списка, номер которого определяется функцией МЕСЯЦ.

Для того, чтобы набрать формулу (3.1) выполните следующие действия:

·         сделайте активной ячейку А2 и вызовите функцию ЕСЛИ;

·         в окне функции ЕСЛИ в поле Логическое_выражеиие напечатайте вручную $B2= «», в

поле значепие_если_истина наберите « », в поле значение_еслн_ложь вызовите функцию ВЫБОР;

·         в окне функции ВЫБОР в поле значение1 напечатайте «Январь», в поле значение2 напечатайте

«Февраль»  и так далее пока не напечатаете все названия месяцем. Затем поставьте текстовый курсор

в поле номер_индекса и вызовите функцию МЕСЯЦ;

·         в окне функции МЕСЯЦ в поле Дата_как_число наберите адрес $B2;

·                   Щелкните кнопку ОК.

9.                В ячейку Е2 набираем следующую формулу:

=ЕСЛИ($D2=« »; “  ”;ПРОСМОТР($D2;Номер товара; Наименование товара)                (3.2)

Правило набора формулы:
Щелкните в ячейку Е2. Установите курсор на значок  Стандартной панели. Откроется окно Мастер функции …, выберите функцию ЕСЛИ.  Выполните действия, которые видите на рисунке

Т.е. в позиции  Лог_выражение щелкните на ячейку D2 и три раза нажмите на клавишу F4 - получите $D2, наберите =« », клавишей Tab или мышью  перейдите в позицию Значение_если_истина и наберите. « », перейдите в позицию Значение_если_ложь – щелкните на кнопку рядом с названием функции и выберите команду Другие функции.. → Категории → Ссылки и массивы, в окне Функции → ПРОСМОТР→ ОК→ ОК.

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Откроется окно функции ПРОСМОТР. В позиции  Искомое_значение щелкните на ячейку D2 и три раза нажмите на клавишу F4 - получите $D2, клавишей Tab или мышью  перейдите в позицию Просматриваемый_вектор и щелкните на ярлык листа «Товары», выделите диапазон  ячеек  А2:А12, нажмите на клавишу F4, перейдите в позицию Вектор_результатов – еще раз щелкните на ярлык листа «Товары», выделите диапазон  ячеек  В2:В12, нажмите на клавишу F4, и ОК. Если выполнили все верно – появится в ячейке #HD

 




Сделайте заливку ячейки  желтым цветом.

10. В ячейку G2 набираем следующую формулу:

=ЕСЛИ($
D2=« »;« »;ПРОСМОТР($D2;Номер товара; Цена))                                                   (3.3)

Сделайте заливку ячейки  желтым цветом.

11. В ячейку I2 набираем следующую формулу:
=ЕСЛИ($Н2=« »;« »;ПРОСМОТР($
H2;Код; Фирма))                                                                   (3.4)
Сделайте заливку ячейки  желтым цветом.

12. В ячейку J2 набираем следующую формулу:
=ЕСЛИ(
F2=« »;« »;F2*G2)                                                                                                                        (3.5)
Сделайте заливку ячейки  желтым цветом..

13. В ячейку K2 набираем следующую формулу:
=ЕСЛИ($Н2=« »;« »;ПРОСМОТР($
H2;Код; Скидка))                                                                  (3.6)
Сделайте заливку ячейки  желтым цветом.

14. В ячейку L2 набираем следующую формулу:
=ЕСЛИ(
J2=« »;« »;J2-J2*K2)                                                                                                                   (3.7)
Сделайте заливку ячейки  желтым цветом.

15. Ячейки В2 , D2 и Н2 – в которых нет формул, залить голубым цветом. Выделите диапазон  А2 – L2 и маркером  заполнения (черный крестик в правом нижнем углу блока) протянуть заливку и формулы  до 31 строки включительно..

16. Сделайте активной ячейку В2 и протяните вниз маркером заполнения до ячейки ВЗ1 включительно.

17. В ячейку С2 напечатайте число 2008-01, которое будет начальным номером заказа и протяните вниз маркером заполнения до ячейки CЗ1 включительно.

18. Теперь необходимо заполнить с клавиатуры столбцы  В2:В31 , D2: D31 и Н2:Н31. С В2 по В11 набираем январские даты (например, 2.01.08, 12.01.08). С В12 по В21 набираем февральские даты (например, 12.02.08, 21.02.08) и с В22 по В31 набираем  мартовские даты (например, 5.03.08, 6.03.08).  В  D2: D31 набираем номера товаров т.е. 101, 102, 103, 104, 201, 202, 203, 204, 301, 302 и 303. Номера могут повторяться и идти в любом порядке, аналогично в  Н2:Н31 вводим Коды  ваших фирм, которые у вас набраны на листе Клиенты.  В столбец F вводим двузначные числа.

19. Вы  с успехом выполнили работу, сдайте ее преподавателю!.

 

 

 

 

 

 



 

Лабораторная работа № 2 Лист

Лабораторная работа № 2 Лист

Откроется окно функции ПРОСМОТР

Откроется окно функции ПРОСМОТР

В ячейку I 2 набираем следующую формулу: =ЕСЛИ($Н2=« »;« »;ПРОСМОТР($

В ячейку I 2 набираем следующую формулу: =ЕСЛИ($Н2=« »;« »;ПРОСМОТР($
Скачать файл