Контрольная работа по информатике «Линейные программы в Паскале» В1.doc

  • doc
  • 14.05.2020
Публикация на сайте для учителей

Публикация педагогических разработок

Бесплатное участие. Свидетельство автора сразу.
Мгновенные 10 документов в портфолио.

Иконка файла материала Контрольная работа по информатике «Линейные программы в Паскале» В1.doc

Контрольная работа по информатике «Линейные программы в Паскале»

 

Вариант 1

 

  1. Для чего предназначен оператор Readln (a)?

а) для ввода данных с клавиатуры;

б) для ввода символьных данных;

в) для печати результатов на принтере;

г) для вывода на экран.

 

  1. Определите результат работы программы:

Writeln (‘5 + 5 =’, 5 + 5)

а) 10 = 10;                              б) 5 + 5 = 10;

в) 20;                                      г) 5+ 5 = 5 + 5.

 

  1. Какое число будет выведено на экран:

Writeln ( - 30 div 5) ?

а) –30  ;                                   б) 0;

в) – 6;                                     г) 6.

 

  1. Определите результат работы программы:

a := - 6; b := - 5; a := a + 2 * b; b := a;  Writeln (a,b).

а) 0, - 16;                                б) – 16, 0;

в) – 16, - 16;                           г) – 6, - 5.

 

  1. Скольких команд вывода достаточно для печати на экране твоей фамилии, имени и отчества?

а) Трех;                                  б) Двух;

в) Одной;                              г) Четырех.

 

  1. Что вычисляет функция SQRT?

а) Остаток от деления;

б) Модуль числа;

в) Квадратный корень;

г) Определяет знак числа.

 

  1. Чему равно значение выражения   -ABS ( - SQRT (36) )?

а) – 6;              б) 6;                в) 36;              г) -36

 

  1. Чему равно значение функции     12 MOD 4?

а) 12;               б) 4;                в) 3;                 г) 0.

 

  1. Чему равно значение выражения

INT (SQRT (37)) + ABS ( - 2 – 6 MOD 3)?

а) 8;                 б) 4;                в) 2;                г) 0.

 

  1. Найдите логически неверно записанную последовательность команд:

а) Readln (F,Y); D:=F*Y; Y:=D+4; Writeln (F);

б) Readln (F,Y); D:=F*Y; Y:=D+4; Writeln (Y);

в) Readln (F,Y); Y:=D+4; d:=F*Y; Writeln (F);

г) Writeln (F); Readln (F,Y); D:=F*Y; Y:=D+4;

 

  1. С какого служебного слова начинается программа:

a) Var;             б) Program;                 в) Begin;                     г) End.

 

  1. Что делает эта программа?

Program Example;

   Var  a, b, S: Integer;

    Begin

           Writeln (‘Введите 2 числа’);

            Readln (a,b);

           S:=a*b;

            Writeln (S);

             Readln;

     End.

а)  находит периметр квадрата;                  б) находит площадь квадрата;

в) находит площадь прямоугольника;      г) находит площадь круга.

                 

  1. Какими двумя действиями можно получить цифры заданного двузначного числа Х?

а) X div 2; X mod 2;                                     б) X div 10; X mod 10;

в) (X div 10) mod 10; (X mod 100) div 10;  г) X div 100; X mod 100.

 

  1. Сколько данных нужно ввести для вычисления площади квадрата?

а) одно;          б) два;             в) три;            г) четыре?

 

 

 

 

 


Скачивание материала доступно только для авторизованных пользователей.