ЛАБОРАТОРНАЯ РАБОТА № 2. «РЕШЕНИЕ ДВУХИНДЕКСНЫХ ЗАДАЧ ЛИНЕЙНОГО ПРОГРАММИРОВАНИЯ
Оценка 4.6

ЛАБОРАТОРНАЯ РАБОТА № 2. «РЕШЕНИЕ ДВУХИНДЕКСНЫХ ЗАДАЧ ЛИНЕЙНОГО ПРОГРАММИРОВАНИЯ

Оценка 4.6
doc
08.05.2020
ЛАБОРАТОРНАЯ РАБОТА № 2. «РЕШЕНИЕ ДВУХИНДЕКСНЫХ ЗАДАЧ ЛИНЕЙНОГО ПРОГРАММИРОВАНИЯ
9. ЛАБОРАТОРНАЯ РАБОТА № 2. «РЕШЕНИЕ ДВУХИНДЕКСНЫХ ЗАДАЧ ЛИНЕЙНОГО ПРОГРАММИРОВАНИЯ.doc

ЛАБОРАТОРНАЯ РАБОТА № 2. «РЕШЕНИЕ ДВУХИНДЕКСНЫХ ЗАДАЧ ЛИНЕЙНОГО ПРОГРАММИРОВАНИЯ

С ИСПОЛЬЗОВАНИЕМ Microsoft Excel. ТРАНСПОРТНАЯ ЗАДАЧА»

 

2.1 ЦЕЛЬ РАБОТЫ

 

Приобретение навыков построения математических моделей стандартных транспортных задач ЛП и решения их в Microsoft Excel.

 

2.2 ОСНОВНЫЕ ПОЛОЖЕНИЯ

 

Задача о размещении (транспортная задача) – это распределительная задача, в которой работы и ресурсы измеряются в одних и тех же единицах. В таких задачах ресурсы могут быть разделены между работами, и отдельные работы могут быть выполнены с помощью различных комбинаций ресурсов. Примером типичной транспортной задачи является распределение (транспортировка) продукции, находящейся на складах, по предприятиям-потребителям.

Стандартная ТЗ определяется как задача разработки наиболее экономичного плана перевозки продукции одного вида из нескольких пунктов отправления в пункты назначения. При этом величина транспортных расходов прямо пропорциональна объему перевозимой продукции и задается с помощью тарифов на перевозку единицы продукции.

 

Исходные параметры модели ТЗ

 

a) n – количество пунктов отправления, m – количество пунктов назначения;

b)  – запас продукции в пункте отправления  () (ед. тов.);

c)  – спрос на продукцию в пункте назначения  () (ед. тов.);

d)  – тариф (стоимость) перевозки единицы продукции из пункта отправления  в пункт назначения  (руб./ед. тов.).

 

Искомые параметры модели ТЗ

 

1  – количество продукции, перевозимой из пункта отправления  в пункт назначения  (ед. тов.).

2  – транспортные расходы на перевозку всей продукции (руб.).

 

Этапы построения модели

Определение переменных.

Проверка сбалансированности задачи.

Построение сбалансированной транспортной матрицы.

Задание ЦФ.

Задание ограничений.

 

Транспортная модель

 

;

(2.1)

 

Целевая функция представляет собой транспортные расходы на осуществление всех перевозок в целом. Первая группа ограничений указывает, что запас продукции в любом пункте отправления должен быть равен суммарному объему перевозок продукции из этого пункта. Вторая группа ограничений указывает, что суммарные перевозки продукции в некоторый пункт потребления должны полностью удовлетворить спрос на продукцию в этом пункте. Наглядной формой представления модели ТЗ является транспортная матрица (табл. 2.1).

 

Таблица 2.1

 

Общий вид транспортной матрицы

 

Пункты

отправления,

Пункты потребления,

Запасы,

(ед. прод.)

Потребность

(ед. прод.)

 

Из модели (2.1) следует, что сумма запасов продукции во всех пунктах отправления должна равняться суммарной потребности во всех пунктах потребления, то есть

 

.

(2.2)

 

Если (2.2) выполняется, то ТЗ называется сбалансированной, в противном случае – несбалансированной. Поскольку ограничения модели (2.1) могут быть выполнены только при сбалансированной ТЗ, то при построении транспортной модели необходимо проверять условие баланса (2.2). В случае, когда суммарные запасы превышают суммарные потребности, необходим дополнительный фиктивный пункт потребления, который будет формально потреблять существующий излишек запасов, то есть

 

.

(2.3)

 

Если суммарные потребности превышают суммарные запасы, то необходим дополнительный фиктивный пункт отправления, формально восполняющий существующий недостаток продукции в пунктах отправления:

 

.

(2.4)

 

Введение фиктивного потребителя или отправителя повлечет необходимость формального задания фиктивных тарифов  (реально не существующих) для фиктивных перевозок.

Поскольку нас интересует определение наиболее выгодных реальных перевозок, то необходимо предусмотреть, чтобы при решении задачи (при нахождении опорных планов) фиктивные перевозки не рассматривались до тех пор, пока не будут определены все реальные перевозки. Для этого надо фиктивные перевозки сделать невыгодными, то есть дорогими, чтобы при поиске решения задачи их рассматривали в самую последнюю очередь. Таким образом, величина фиктивных тарифов должна превышать максимальный из реальных тарифов, используемых в модели, то есть

 

.

 

На практике возможны ситуации, когда в определенных направлениях перевозки продукции невозможны, например, по причине ремонта транспортных магистралей. Такие ситуации моделируются с помощью введения так называемых запрещающих тарифов . Запрещающие тарифы должны сделать невозможными, то есть совершенно невыгодными, перевозки в соответствующих направлениях. Для этого величина запрещающих тарифов должна превышать максимальный из реальных тарифов, используемых в модели:

 

.

 

2.3 ПОРЯДОК ВЫПОЛНЕНИЯ РАБОТЫ

 

1 Согласно номеру своего варианта выберите условие задачи.

2 Постройте модель задачи, включая транспортную таблицу.

3 Найдите оптимальное решение задачи в Excel и продемонстрируйте его преподавателю.

4 Оформите отчет по лабораторной работе.

Двухиндексные задачи ЛП вводятся и решаются в Excel аналогично одноиндексным задачам. Специфика ввода условия двухиндексной задачи ЛП состоит лишь в удобстве матричного задания переменных задачи и коэффициентов ЦФ.

Рассмотрим решение двухиндексной задачи, суть которой заключается в оптимальной организации транспортных перевозок штучного товара от поставщиков потребителям (табл. 2.2).

 

Таблица 2.2

 

Исходные данные транспортной задачи

 

Тарифы, руб./шт.

1-й потребитель

2-й потреби-тель

3-й потреби-тель

4-й потребитель

5-й потреби-тель

Запасы, шт.

1-й поставщик

1

4

2

1

6

4

2-й поставщик

4

1

3

2

3

15

3-й поставщик

6

3

1

5

2

18

Потребности, шт.

10

6

4

8

9

 

 

Целевая функция и ограничения данной задачи имеют вид

 

(2.5)

 

Экранные формы, задание переменных, целевой функции, ограничений и граничных условий двухиндексной задачи (2.5) и ее решение представлены на рис. 2.1, 2.2, 2.3 и в табл. 2.3.

 

1 картинка

 

Рис. 2.1. Экранная форма двухиндексной задачи (2.5)

(курсор в целевой ячейке Н13)

 


Таблица 2.3

 

Формулы экранной формы задачи (2.5)

 

Объект математической модели

Выражение в Excel

Переменные задачи

C3:G5

Формула в целевой ячейке H13

=СУММПРОИЗВ(C3: G5;C11:G13)

Ограничения по строкам

в ячейках H3, H4, H5

=СУММ(C3: G3)

=СУММ(C4: G4)

=СУММ(C5: G5)

Ограничения по столбцам

в ячейках С6, D6, E6,F6,G6

=СУММ(C3:C5)

=СУММ(D3:D5)

=СУММ(E3:E5)

=СУММ(F3:F5)

=СУММ(G3:G5)

Суммарные запасы и потребности

в ячейках J7, I8

=СУММ(J3:J5)

=СУММ(C8:G8)

 

2 картинка

 

Рис. 2.2. Ограничения и граничные условия задачи (2.5)

 

3 картинка

 

Рис. 2.3. Экранная форма после получения решения задачи (2.5)

(курсор в целевой ячейке H13)

 

2.4 СОДЕРЖАНИЕ ОТЧЕТА

 

Отчет должен содержать:

·                                           титульный лист (см. рис. 2.1);

·                                           номер варианта

·                                           транспортную таблицу и модель задачи в Microsoft Excel с указанием всех единиц измерения;

·                                           результаты решения задачи с указанием единиц измерения.

Обязательно наличие выводов по проделанной работе. В случае несвоевременного выполнения задания к отчету прилагается дискета с выполненным заданием.

 

2.5 КОНТРОЛЬНЫЕ ВОПРОСЫ

 

1 Что такое задача о размещении?

2 Какова постановка стандартной ТЗ?

3 Запишите математическую модель ТЗ.

4 Перечислите исходные и искомые параметры модели ТЗ.

5 Какова суть каждого из этапов построения модели ТЗ?

6 Раскройте понятие сбалансированности ТЗ.

7 Что такое фиктивные тарифы?

 

2.6 ЗАДАНИЯ

 

Используя MS Excel, найти решение ТЗ, соответствующей заданному варианту (табл. 2.4).

Таблица 2.4

 

№ варианта

Кол-во груза, провозимое поставщиками, ед.тов.

Кол-во груза, необходимое потребителям, ед.тов.

Тарифы на перевозки, руб./ед.тов.

 

А1

А2

А3

В1

В2

В3

В4

В5

Первым поставщиком и соотв. всеми

потребителями

А1В1/В2/В3/В4/В5

Первым поставщиком и соотв. всеми потребителями

А2В1/В2/В3/В4/В5

Первым поставщиком и соотв. всеми потребителями

А3В1/В2/В3/В4/В5

1

20

15

6

11

4

6

8

12

9/4/2/1/3

1/5/6/3/1

2/1/4/7/2

2

8

16

30

15

7

22

6

4

3/2/1/4/7

2/1/3/2/2

6/3/2/1/3

3

28

21

17

5

26

14

16

-

2/3/5/7/-

5/2/3/1/-

3/1/4/2/-

4

14

8

30

19

11

5

10

7

4/1/3/2/5

2/4/1/6/3

3/6/5/4/1

5

32

13

10

12

19

6

4

14

1/5/2/3/2

3/1/4/2/7

5/2/3/1/6

6

17

31

24

9

5

15

18

25

3/2/5/1/4

4/3/1/2/5

1/9/4/3/2

7

43

10

21

14

24

10

22

4

4/1/7/3/2

2/3/5/2/1

1/2/3/8/4

8

36

28

19

21

15

27

17

-

5/3/1/2/-

3/1/2/4/-

3/4/5/1/-

9

15

14

35

7

12

18

15

12

2/7/5/1/3

8/5/1/3/2

1/6/4/2/5

10

32

25

16

18

9

15

7

24

1/4/2/7/5

6/2/4/1/3

4/3/5/2/1

11

10

30

20

8

16

17

6

13

7/2/1/5/3

4/3/2/4/1

6/1/3/3/2

12

45

54

27

31

42

15

28

10

20/15/19/8/31

7/12/26/30/15

11/6/41/24/5

 


Скачано с www.znanio.ru

ЛАБОРАТОРНАЯ РАБОТА № 2. «РЕШЕНИЕ

ЛАБОРАТОРНАЯ РАБОТА № 2. «РЕШЕНИЕ

Проверка сбалансированности задачи

Проверка сбалансированности задачи

Если (2.2) выполняется, то ТЗ называется сбалансированной , в противном случае – несбалансированной

Если (2.2) выполняется, то ТЗ называется сбалансированной , в противном случае – несбалансированной

Для этого величина запрещающих тарифов должна превышать максимальный из реальных тарифов, используемых в модели:

Для этого величина запрещающих тарифов должна превышать максимальный из реальных тарифов, используемых в модели:

Экранные формы, задание переменных, целевой функции, ограничений и граничных условий двухиндексной задачи (2

Экранные формы, задание переменных, целевой функции, ограничений и граничных условий двухиндексной задачи (2

Таблица 2.3 Формулы экранной формы задачи (2

Таблица 2.3 Формулы экранной формы задачи (2

Рис. 2.3. Экранная форма после получения решения задачи (2

Рис. 2.3. Экранная форма после получения решения задачи (2

Используя MS Excel , найти решение

Используя MS Excel , найти решение
Скачать файл