Тест «Исполнители и алгоритмы»
Оценка 4.6

Тест «Исполнители и алгоритмы»

Оценка 4.6
doc
13.05.2020
Тест «Исполнители и алгоритмы»
14. Тест «Исполнители и алгоритмы».doc

Тест «Исполнители и алгоритмы»

 

1. Исполнитель Мурсик перемещается на экране компьютера, оставляя след в виде линии. В каждый конкретный момент известно положение исполнителя и направление его движения. У исполнителя существуют две команды: «Вперед G», где G – целое число, вызывающая передвижение Мурсика на G шагов в направлении движения, и «Направо N», где N – целое число, вызывающая изменение направления движения на N градусов по часовой стрелке. Запись «Повтори Z [Команда1 Команда2]» означает, что последовательность команд в скобках повторится Z раз. Мурсику был дан для исполнения следующий алгоритм: «Повтори 5 [Вперед 10 Направо 90]». Какая фигура появится на экране?

 

1) незамкнутая ломаная линия

2) правильный треугольник

3) пятиугольник

4) квадрат

 

2. Исполнитель Мурсик перемещается на экране компьютера, оставляя след в виде линии. В каждый конкретный момент известно положение исполнителя и направление его движения. У исполнителя существуют две команды: «Вперед G», где G – целое число, вызывающая передвижение Мурсика на G шагов в направлении движения, и «Направо N», где N – целое число, вызывающая изменение направления движения на N градусов по часовой стрелке. Запись «Повтори Z [Команда1 Команда2]» означает, что последовательность команд в скобках повторится Z раз. Мурсику был дан для исполнения следующий алгоритм: «Повтори 5 [Вперед 10 Направо 120]». Какая фигура появится на экране?

 

1) незамкнутая ломаная линия

2) правильный треугольник

3) квадрат

4) правильный пятиугольник

 

 

Бланк ответов

№ вопроса

№ ответа

1

 

2

 


Дополнительное задание: используя инструмент «Автофигуры» нарисуйте схему движения исполнителя Мурсик в обоих случаях.


Тест «Исполнители и алгоритмы» 1

Тест «Исполнители и алгоритмы» 1
Скачать файл