Контрольная работа по информатике 9 класс (Программирование)

  • docx
  • 06.05.2025
Публикация на сайте для учителей

Публикация педагогических разработок

Бесплатное участие. Свидетельство автора сразу.
Мгновенные 10 документов в портфолио.

Иконка файла материала кр по паскалю.docx

Задача 2 (урок 19.12.2017)
Составьте программу, задающую одномерный массив целых чисел из 6 элементов, вводимых с клавиатуры, и оформите вывод элементов на экран в строчку.

текст
программы
program m14;
var m: array [1..6] of integer;
    i: integer;
begin
for i:=1 to 6 do
begin
writeln('
Ведите ',i,' элемент');
readln(m[i]);
end;
clrscr;
for i:=1 to 6 do write(m[i],' ');
end.

Формирование массива с помощью функции случайных чисел random. 


Задача 3 (урок 19.12.2017)

Составьте программу, задающую одномерный массив размерность 10, состоящий из случайных чисел из промежутка  от 5 до 22. Оформите вывод элементов на экран в строчку.
Пояснение. 
Обратите внимание, что случайные числа задаются функцией random(x). Для того чтобы задать случайные числа из промежутка от a до b есть формула x:=random(b-a+1)+a, в нашем случае
x:=random(18)+5

текст программы

uses crt;

var m: array [1..10] of integer;

    i: integer;

begin

for i:=1 to 10 do

begin

m[i]:= Random(18)+5;

write(m[i],' ');

end;

end.

Задача 5 (урок )

Составьте программу, которая в одномерном массиве размерностью 8 (элементы массива случайные числа из промежутка от 15 до 100) находит максимальный элемент.  Оформите вывод элементов на экран в строчку, максимальный на следующей строке.

Пояснение 
Обратите внимание, что это задание аналогично задаче 7. Но в данном случае при составление программы используется массив.


текст программы

uses crt;

var m:array[1..8] of integer;

    i,max:integer;

begin

max:=14;

for i:=1 to 8 do

begin

m[i]:=random(86)+15;

write(m[i],' ');

if max<m[i] then max:=m[i];

end;

writeln;

writeln('Максимальный - ',max);

end.


 

Задача 2 
Составьте программу, задающую одномерный массив целых чисел из 6 элементов, вводимых с клавиатуры, и оформите вывод элементов на экран в строчку.

Задача 3 
Составьте программу, задающую одномерный массив размерность 10, состоящий из случайных чисел из промежутка  от 5 до 22. Оформите вывод элементов на экран в строчку.

Задача 5 

Составьте программу, которая в одномерном массиве размерностью 8 (элементы массива случайные числа из промежутка от 15 до 100) находит максимальный элемент.  Оформите вывод элементов на экран в строчку, максимальный на следующей строке.

Задача 2 
Составьте программу, задающую одномерный массив целых чисел из 6 элементов, вводимых с клавиатуры, и оформите вывод элементов на экран в строчку.

Задача 3 
Составьте программу, задающую одномерный массив размерность 10, состоящий из случайных чисел из промежутка  от 5 до 22. Оформите вывод элементов на экран в строчку.

Задача 5 

Составьте программу, которая в одномерном массиве размерностью 8 (элементы массива случайные числа из промежутка от 15 до 100) находит максимальный элемент.  Оформите вывод элементов на экран в строчку, максимальный на следующей строке.

Задача 2 
Составьте программу, задающую одномерный массив целых чисел из 6 элементов, вводимых с клавиатуры, и оформите вывод элементов на экран в строчку.

Задача 3 
Составьте программу, задающую одномерный массив размерность 10, состоящий из случайных чисел из промежутка  от 5 до 22. Оформите вывод элементов на экран в строчку.

Задача 5 

Составьте программу, которая в одномерном массиве размерностью 8 (элементы массива случайные числа из промежутка от 15 до 100) находит максимальный элемент.  Оформите вывод элементов на экран в строчку, максимальный на следующей строке.

Задача 2 
Составьте программу, задающую одномерный массив целых чисел из 6 элементов, вводимых с клавиатуры, и оформите вывод элементов на экран в строчку.

Задача 3 
Составьте программу, задающую одномерный массив размерность 10, состоящий из случайных чисел из промежутка  от 5 до 22. Оформите вывод элементов на экран в строчку.

Задача 5 

Составьте программу, которая в одномерном массиве размерностью 8 (элементы массива случайные числа из промежутка от 15 до 100) находит максимальный элемент.  Оформите вывод элементов на экран в строчку, максимальный на следующей строке.

Задача 2 
Составьте программу, задающую одномерный массив целых чисел из 6 элементов, вводимых с клавиатуры, и оформите вывод элементов на экран в строчку.

Задача 3 
Составьте программу, задающую одномерный массив размерность 10, состоящий из случайных чисел из промежутка  от 5 до 22. Оформите вывод элементов на экран в строчку.

Задача 5 

Составьте программу, которая в одномерном массиве размерностью 8 (элементы массива случайные числа из промежутка от 15 до 100) находит максимальный элемент.  Оформите вывод элементов на экран в строчку, максимальный на следующей строке.


 

Посмотрите также