Краткосрочный план урока информатики на тему "Программа и её структура." (7 класс)
Оценка 4.8

Краткосрочный план урока информатики на тему "Программа и её структура." (7 класс)

Оценка 4.8
Разработки уроков
docx
информатика
7 кл
30.06.2017
Краткосрочный план урока информатики на тему "Программа и её структура." (7 класс)
Краткосрочный план урока информатики для 7 класса на тему "Программа и её структура", на котором учащиеся должны познакомиться со структурой программы на языке программирования Паскаль и научиться создавать простейшие программы. Для актуализации знаний учащихся. используется игра «Согласен - не согласен».
9-Программа и ее структура..docx

Краткосрочный план урока

Предмет: информатика

Класс: 7

Дата: 29.10-09.11.16

ФИО учителя: Кожахметова Ж.Ш.

Тема урока:

Программа и её структура.

Цели обучения, которым способствует данный урок:

Учащиеся должны познакомиться со структурой программы на языке программирования Паскаль и научиться создавать простейшие программы.

Цели урока:

 

Все учащиеся будут знать:

общую структуру программы;

ключевые слова program, begin и end;

операторы вывода текста на экран write и writeln.

Большинство учащихся смогут:

создать простейшую программу;

запустить компиляцию программы;

определить значение переменной после исполнения алгоритма.

Некоторые учащиеся будут знать:

отличие операторов вывода write и writeln;

смогут:

создать усложнённую программу с выводом нескольких строк.

Предыдущее обучение:

Языки программирования. Алфавит и синтаксис языка.

 

План

Этапы урока

Запланированная деятельность

Ресурсы

Вызов

0-10

1) Организационный момент.

 

2) Актуализация знаний учащихся. Игра «Согласен - не согласен». Взаимопроверка.

1. Любая информация в компьютере представлена в двоичном коде. (+)

2. Компиляция - это процесс перевода с двоичного кода на язык программирования. (-) 

3. Для каждого языка программирования существует свой компилятор. (+)

4. В результате работы компилятора из исходника формируется исполняемыйEXE-файл. (+)

5. Алфавит языка - это правила записи команд. (-)

6. Синтаксис языка - это определённый набор символов. (-)

7. Идентификатор - это совокупность букв, цифр и символа подчёркивания. (+)

8. Компилятору всё равно на каком языке вы пишите программу. (-)

9. Пробел - это символ. (+)

10. В тексте программы нельзя использовать комментарии.

(-)

 

 

Осмысление

11-40

1) Просмотр ЦОР №2188 «Структура программы на языке программирования».

 

2) Работа с учебником. Изучение §9 «Программа и её структура» на стр. 55-56.

 

3) Создание простейшей программы.

Programpr1;

begin

write ('Моя первая программа');

end.

 

4) Выполнение заданий.

1. Написать программу, выводящую на экран фразу «Я изучаю информатику».

 

2. Определить значение переменной m после исполнения данного алгоритма:

k:=2

m:=k - 2

k:=m*k+5

m:=m+2

k:=-1

m:=2*k - 2

k:=m+2

m:=k*m+5

k:=3

m:=k+1

k:=m*k+5

k:=k - 10

k:=32

m:=k/4 - 5

k:=3+m*4

m:=m - k

m=2

m=13

m=4

m=-12

 

3. Составить программу, которая выводит на экран монитора сведения о названии и авторе программы:

**********************************

*                     Программа                        *

*               Первая программа                  *

*          Автор: ФИО                                 *  

**********************************  

 

Портал e.edu.kz.

 

 

Учебник.

 

 

Программа PascalABC.

 

 

 

 

 

Рефлексия

41-45

1) Постановка домашнего задания: §9.

 

2) Учащимся предлагается продолжить предложение:

Сегодня на уроке я узнал...

Сегодня на уроке я понял...

Сегодня на уроке у меня получилось...

Сегодня на уроке мне было...

 

 

 

 

 

                                                    


 

Краткосрочный план урока

Краткосрочный план урока

Осмысление 11-40 1) Просмотр

Осмысление 11-40 1) Просмотр
Материалы на данной страницы взяты из открытых истончиков либо размещены пользователем в соответствии с договором-офертой сайта. Вы можете сообщить о нарушении.
30.06.2017