Система уроков по информатике по теме программирование на языке Pascal.ABC
Пархоменко Эльмира Ильясовна, учитель информатики и ИКТ,
МБОУ СОШ №79 Октябрьского района города Ростова-на-Дону
Урок 2.
Тема урока: Программирование алгоритмов разветвляющейся структуры.
Тип урока: урок закрепления новых знаний, повторения пройденного материала,
подготовка к ЕГЭ по информатике.
Продолжительность урока: 45 минут
Оборудование и материалы:
персональные компьютеры с операционной системой MS Windows XP и системой
программирования Pascal ABC;
проектор;
экран;
Приложение 1 (работа по вариантам: Анализ алгоритмов);
Цели урока:
предметные:
повторить и проконтролировать степень усвоения основных знаний, умений и навыков,
изученных и сформированных на предыдущих уроках по информатике с помощью карточек;
обобщить и систематизировать знания по теме «Алгоритмические конструкции»
математическими приемами;
продолжить формирование умений и навыков построения блок-схем алгоритма, построение
программ с помощью языка программирования Pascal ABC.
закрепить программный материал посредством решения задач, построения блок-схем и
программ;
вырабатывать умения точно и грамотно выражать свои мысли в устной и письменной речи
с применением терминологии и символики, умение работать с текстом, извлекая необходимую
информацию.
метапредметные:
развивать интерес к логике и информатике;
развивать логическое мышление, память и внимательность; аккуратность при составлении
блок-схем, алгоритмов и программ;
вырабатывать умение использовать математические средства наглядности (схемы);
формировать информационную культуру, компьютерную грамотность и потребность в
приобретении знаний.
личностно-ориентированные:
развивать познавательный интерес и творческую активность;
прививать учащимся навыки самостоятельности в работе;
повышать соревновательные качества учащихся на уроке;
вырабатывать аккуратность и организованность в работе;
демонстрировать возможности применения компьютеров, для решения задач;
формировать навыки взаимодействия и принятия решений;
воспитывать коллективизм и ответственность за коллективную работу.
Формы организации работы на уроке:
индивидуальная;
групповая;
самостоятельная (дифференцированная по трудности).
Литература
УМК по информатике под редакцией И. Семакина;
УМП
«Подготовка к ЕГЭ. Сборник задач по программированию» под редакцией
Ф.Ф. Лысенко, Л.Н. Евич, издательство Легион 2012 г.
Преподавание базового курса информатики в средней школе. Методическое пособие.
И.Семакин, Т. Шеина.
Межпредметные связи: математика;
информатика
Ход урока
I. Организационный момент (1-2 мин)
II. Сообщение темы, целей урока
III. Проверка домашнего задания (5 мин)
IV. Актуализация знаний (5 мин)
1. Сформулировать понятие алгоритма ветвящейся структуры – алгоритм, в котором все
действия (команды) выполняются в зависимости от выполнения некоторого условия. В
зависимости от результата проверки условия (“да” или “нет”) осуществляется выбор одного из
альтернативных путей работы алгоритма. Каждый из путей ведет к общему выходу, поэтому
работа алгоритма будет продолжаться независимо от того, какой путь будет выбран.
2. Повторить вид блок-схемы алгоритмической структуры разветвляющегося алгоритма.
Структура «Если – то»
да
условие
действ
ия
не
т
3. Повторить вид блок-схемы алгоритмической структуры разветвляющегося алгоритма.
Структура «Если - то – иначе»
да
условие
действия
1
не
т
действия
2
4. Определить значение переменной в результате выполнения алгоритма представленного в
виде блок-схемы. Задание по вариантам (Приложение 3. Информатика и ИКТ. Подготовка к ЕГЭ
под ред. Лысенко Ф.Ф., Евич Л.Н., стр. 38-39).
V. Объяснение нового материала (10 мин).
Разветвляющиеся алгоритмы на языке Паскаль программируются с помощью конструкий:
Структура «Если - то»
if условие then begin
операторы;
end;
Структура «Если – то –иначе»
if условие then begin
операторы;
end
else begin
операторы;
end;
Пример 2.1. Дано целое положительное число n. Составьте программу, которая, если число
четное, выводит последнюю цифру этого числа.
1. Постановка задачи. Входные данные – положительное число n. Выходные данные –
последняя цифра числа, если n четное. 2. Математическая модель. Последняя цифра числа находится как остаток от деления
заданного числа n на 10. Четность числа определяем, как деление числа на 2 без
остатка (т.е. остаток равен 0).
Программа на Pascal
program poclcifra;
var n, m: integer;
begin
read(n);
if n mod 2 =0 then begin
m:=n mod 10;
writeln(m);
end;
end.
3. Алгоритм решения.
1) Введите число n
2) Определяем четность числа
3) Если число четное, находим остаток.
4) Выводим на печать.
Блок-схема
poclcifra
n
n mod 2=0
д
m:=n mod 10
m
нет
конец
Особенности.
1. Строка перед оператором else не заканчивается знаком «;»
2. Операторы begin и end могут отсутствовать, если операторы в теле цикле только один.
Пример 2.2. Даны два целых числа а и b. Составьте программу определяющую наибольшее
из них.
Трассирующая таблица
b
3
a>b
Да
a
4
4
Блок-схема
srav
a, b
a>b
a
b
конец
Программа на Pascal
program srav;
var a, b: integer;
begin
read(a, b);
if a>b then begin
writeln(a);
end
else begin
writeln(b);
end;
end.
V Задания для работы c самопроверкой (20 мин) (Информатика и ИКТ. Подготовка к
ЕГЭ под ред. Лысенко Ф.Ф., Евич Л.Н., стр. 33).
Задачи. 1. Дано число x. Составьте программу, которая находит значение √х+1
2. Даны два действительных числа. Составьте программу, которая выводит первое
число, если оно не больше второго, или их сумму в противном случае.
3. Даны два действительных числа. Составьте программу, которая меньшее из них
заменяет полу суммой, а большее произведением.
4. Даны три числа, определить наибольшее из них.
5. Даны три числа x, y,z Составьте программу, которая находит max(x+y+z, xy/z).
6. Даны четыре числа, определить наибольшее из них.
7. Даны три числа, определить есть ли среди них хотя бы одно четное.
Учитель информатики проверяет правильность выполнения задания, выставляет оценки.
Итог урока (3 мин):
Рефлексия
VII. Постановка домашнего задания (3 мин):
Разработать разветвляющийся алгоритм и написать программу для решения
какой-либо задачи практического содержания.
Разработка урока информатики по теме "Программирование на языке Pascal.ABC"
Разработка урока информатики по теме "Программирование на языке Pascal.ABC"
Разработка урока информатики по теме "Программирование на языке Pascal.ABC"
Разработка урока информатики по теме "Программирование на языке Pascal.ABC"
Материалы на данной страницы взяты из открытых истончиков либо размещены пользователем в соответствии с договором-офертой сайта. Вы можете сообщить о нарушении.